dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / games-engines / nazghul / nazghul-0.7.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils vcs-clean
7
8 DESCRIPTION="A computer role-playing game (CRPG) engine with game called HaximA"
9 HOMEPAGE="http://myweb.cableone.net/gmcnutt/nazghul.html"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="media-libs/libpng:0
18         >=media-libs/libsdl-1.2.3[X,sound,video]
19         media-libs/sdl-image[png]
20         media-libs/sdl-mixer[midi,vorbis,wav]"
21 RDEPEND="${DEPEND}"
22
23 src_prepare() {
24         ecvs_clean
25
26         default
27 }
28
29 src_install() {
30         default
31         dodoc doc/{GAME_RULES,GHULSCRIPT,MAP_HACKERS_GUIDE,USERS_GUIDE}
32
33         dodoc doc/*html
34         dodoc doc/*gif
35
36         docinto engine_extension_and_design
37         dodoc doc/engine_extension_and_design/*
38
39         docinto world_building
40         dodoc doc/world_building/*
41
42         doicon icons/haxima.png
43         make_desktop_entry haxima.sh HaximA haxima
44 }