dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / games-engines / exult / exult-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools multilib eutils git-r3
6
7 DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
8 HOMEPAGE="http://exult.sourceforge.net/"
9 EGIT_REPO_URI="https://github.com/exult/exult"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE="+sdl2 timidity zlib"
15
16 DEPEND="
17         >=media-libs/libpng-1.2.43-r2:0
18         games-misc/exult-sound
19         media-libs/libvorbis
20         sdl2? ( media-libs/libsdl2[sound,video,X] )
21         !sdl2? ( media-libs/libsdl[sound,video,X] )
22         timidity? ( >=media-sound/timidity++-2 )
23         zlib? ( sys-libs/zlib )
24 "
25 RDEPEND="${DEPEND}"
26
27 S=${WORKDIR}/${P/_/}
28 DOCS=(
29         AUTHORS ChangeLog FAQ NEWS README README.1ST
30 )
31
32 src_prepare() {
33         default
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 --x-libraries="/usr/$(get_libdir)" \
40                 --disable-tools \
41                 --disable-opengl \
42                 --enable-mods \
43                 --with-desktopdir=/usr/share/applications \
44                 --with-icondir=/usr/share/pixmaps \
45                 --with-sdl=$(usex sdl2 sdl2 sdl12) \
46                 $(use_enable timidity timidity-midi) \
47                 $(use_enable zlib zip-support)
48 }
49
50 pkg_postinst() {
51         elog "You *must* have the original Ultima7 The Black Gate and/or"
52         elog "The Serpent Isle installed."
53         elog "See documentation in /usr/share/doc/${PF} for information."
54 }