www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / games-board / pioneers / pioneers-15.3-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="A clone of the popular board game The Settlers of Catan"
8 HOMEPAGE="http://pio.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/pio/${P}.tar.gz"
10
11 LICENSE="GPL-2 CC-BY-SA-4.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="dedicated help nls"
15
16 # dev-util/gob only for autoreconf
17 RDEPEND=">=dev-libs/glib-2.26:2
18         !dedicated?     (
19                 >=x11-libs/gtk+-3.4:3
20                 >=x11-libs/libnotify-0.7.4
21                 help? (
22                         app-text/rarian
23                         >=gnome-base/libgnome-2.10
24                 )
25         )
26         nls? ( virtual/libintl )"
27 DEPEND="${RDEPEND}
28         dev-util/gob:2
29         virtual/pkgconfig
30         nls? ( sys-devel/gettext )"
31
32 src_prepare() {
33         gnome2_src_prepare
34 }
35
36 src_configure() {
37         gnome2_src_configure \
38                 $(use_enable nls) \
39                 $(use_enable help) \
40                 --includedir=/usr/include \
41                 $(use_with !dedicated gtk)
42 }
43
44 src_install() {
45         DOCS='AUTHORS ChangeLog README TODO NEWS' \
46                 gnome2_src_install scrollkeeper_localstate_dir="${ED%/}"/var/lib/scrollkeeper/
47 }