dev-python/jaraco-collections: keyworded 3.0.0 for ia64, bug #717946
[gentoo.git] / games-board / gnome-mines / gnome-mines-3.34.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome.org gnome2-utils meson vala xdg
6
7 DESCRIPTION="Clear hidden mines from a minefield"
8 HOMEPAGE="https://wiki.gnome.org/Apps/Mines"
9
10 LICENSE="GPL-3+ CC-BY-SA-3.0"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~arm64 x86"
13 IUSE=""
14
15 RDEPEND="
16         >=dev-libs/glib-2.40:2
17         dev-libs/libgee:0.8
18         >=x11-libs/gtk+-3.12:3
19         dev-libs/libgnome-games-support:1=
20         >=gnome-base/librsvg-2.32.0:2
21 "
22 DEPEND="${RDEPEND}"
23 BDEPEND="
24         $(vala_depend)
25         dev-libs/appstream-glib
26         dev-libs/libxml2:2
27         dev-util/itstool
28         >=sys-devel/gettext-0.19.8
29         virtual/pkgconfig
30         gnome-base/librsvg:2[vala]
31 "
32
33 src_prepare() {
34         xdg_src_prepare
35         vala_src_prepare
36 }
37
38 pkg_postinst() {
39         xdg_pkg_postinst
40         gnome2_schemas_update
41 }
42
43 pkg_postrm() {
44         xdg_pkg_postrm
45         gnome2_schemas_update
46 }