dev-python/jaraco-collections: keyworded 3.0.0 for ia64, bug #717946
[gentoo.git] / games-board / cockatrice / cockatrice-20190304-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 MY_PV="2019-03-04-Release-2.7.0"
9 DESCRIPTION="An open-source multiplatform software for playing card games over a network"
10 HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
11 SRC_URI="https://github.com/Cockatrice/Cockatrice/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="+client +oracle server"
17
18 RDEPEND="
19         dev-qt/qtconcurrent:5
20         dev-qt/qtprintsupport:5
21         dev-qt/qtcore:5
22         dev-qt/qtgui:5
23         dev-qt/qtnetwork:5[ssl]
24         dev-qt/qtwebsockets:5
25         dev-qt/qtwidgets:5
26         client? (
27                 dev-libs/protobuf:=
28                 dev-qt/qtmultimedia:5
29                 dev-qt/qtprintsupport:5
30                 dev-qt/qtsvg:5
31         )
32         oracle? ( sys-libs/zlib )
33         server? (
34                 dev-libs/protobuf:=
35                 dev-qt/qtsql:5
36                 dev-qt/qtwebsockets:5
37         )
38 "
39 BDEPEND="
40         dev-qt/linguist-tools:5
41         client? ( dev-libs/protobuf )
42         server? ( dev-libs/protobuf )
43 "
44 DEPEND="${RDEPEND}
45 "
46
47 # As the default help/about display the sha1 we need it
48 SHA1='294b433'
49
50 S="${WORKDIR}/Cockatrice-${MY_PV}"
51
52 PATCHES=(
53         "${FILESDIR}"/use-ccache.patch
54 )
55
56 src_configure() {
57         local mycmakeargs=(
58                 -DBUILD_SHARED_LIBS=OFF
59                 -DUSE_CCACHE=OFF
60                 -DWITH_CLIENT=$(usex client)
61                 -DWITH_ORACLE=$(usex oracle)
62                 -DWITH_SERVER=$(usex server)
63                 -DICONDIR="${EPREFIX}/usr/share/icons"
64                 -DDESKTOPDIR="${EPREFIX}/usr/share/applications" )
65
66         # Add date in the help about, come from git originally
67         sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${SHA1}'\")/' \
68                 -i cmake/getversion.cmake || die "sed failed!"
69
70         cmake_src_configure
71 }