games-arcade/trailblazer: Port to EAPI 7
[gentoo.git] / games-arcade / trailblazer / trailblazer-0.9-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Guide a ball through a succession of levels while avoiding holes"
9 HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
10 SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 DEPEND="media-libs/libsdl[video]"
17 RDEPEND="${DEPEND}"
18
19 PATCHES=(
20         "${FILESDIR}"/${P}-gentoo-fhs.patch
21         "${FILESDIR}"/${P}-makefile.patch
22 )
23
24 src_configure() {
25         tc-export CC
26 }
27
28 src_install() {
29         dobin trailblazer
30         dodoc README
31
32         insinto /usr/share/${PN}
33         doins trail.dat
34
35         dodir /var/trailblazer
36         touch "${ED}"/var/trailblazer/trail.time
37         fperms 660 /var/trailblazer/trail.time
38 }