games-arcade/syobon: Cleanup due to #261692
[gentoo.git] / games-arcade / syobon / syobon-1.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit games
7
8 MY_P="${PN}_${PV}_src"
9
10 DESCRIPTION="Syobon Action (also known as Cat Mario or Neko Mario)"
11 HOMEPAGE="http://zapek.com/?p=189"
12 SRC_URI="http://download.zapek.com/software/${PN}/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 RDEPEND="media-libs/libsdl[sound,video,joystick]
20         media-libs/sdl-gfx
21         media-libs/sdl-image[png]
22         media-libs/sdl-ttf
23         media-libs/sdl-mixer[vorbis]"
24
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig"
27
28 S=${WORKDIR}/${PN}
29
30 src_compile() {
31         emake GAMEDATA="${GAMES_DATADIR}/${PN}"
32 }
33
34 src_install() {
35         dogamesbin ${PN}
36
37         insinto "${GAMES_DATADIR}/${PN}"
38         doins -r BGM SE res
39         dodoc README.txt
40         prepgamesdirs
41 }