games-arcade/performous: Fix gcc-5 build. Bug #570572
[gentoo.git] / games-arcade / primateplunge / primateplunge-1.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils games
7
8 DESCRIPTION="Help poor Monkey navigate his way down through treacherous areas"
9 HOMEPAGE="http://www.aelius.com/primateplunge/"
10 SRC_URI="http://www.aelius.com/${PN}/${P}.tar.gz"
11
12 LICENSE="Primate-Plunge"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~x86-fbsd"
15 IUSE=""
16 RESTRICT="mirror bindist" #465850
17
18 DEPEND="media-libs/libsdl[sound,video]
19         media-libs/sdl-mixer"
20 RDEPEND=${DEPEND}
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${P}-AC_SUBST.patch
24         eautoreconf
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install
29         dodoc AUTHORS README TIPS
30         newicon graphics/idle.bmp ${PN}.bmp
31         make_desktop_entry ${PN} "Primate Plunge" /usr/share/pixmaps/${PN}.bmp
32         prepgamesdirs
33 }