games-arcade/gnome-nibbles: remove old
[gentoo.git] / games-arcade / pengupop / pengupop-2.2.5-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools desktop gnome2-utils
6
7 DESCRIPTION="Networked multiplayer-only Puzzle Bubble clone"
8 HOMEPAGE="http://freshmeat.net/projects/pengupop"
9 SRC_URI="mirror://gentoo/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="media-libs/libsdl[sound,video]
17         sys-libs/zlib"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         default
22
23         eapply "${FILESDIR}"/${P}-underlink.patch
24
25         sed -i \
26                 -e '/Icon/s/\.png//' \
27                 -e '/^Encoding/d' \
28                 -e '/Categories/s/Application;//' \
29                 pengupop.desktop || die
30
31         sed -i \
32                 -e 's/-g -Wall -O2/-Wall/' \
33                 Makefile.am || die
34
35         mv configure.in configure.ac || die
36         eautoreconf
37 }
38
39 src_install() {
40         default
41         domenu pengupop.desktop
42         doicon -s 48 pengupop.png
43 }
44
45 pkg_preinst() {
46         gnome2_icon_savelist
47 }
48
49 pkg_postinst() {
50         gnome2_icon_cache_update
51 }
52
53 pkg_postrm() {
54         gnome2_icon_cache_update
55 }