games-arcade/gnome-nibbles: amd64 stable wrt bug #717144
[gentoo.git] / games-arcade / orthorobot / orthorobot-0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils
6
7 DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
8 HOMEPAGE="https://stabyourself.net/orthorobot/"
9 SRC_URI="https://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
10
11 LICENSE="CC-BY-NC-ND-3.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 RDEPEND=">=games-engines/love-0.8.0:0"
16 DEPEND="app-arch/unzip"
17
18 S="${WORKDIR}"
19
20 src_unpack() {
21         default
22         #it is only one .love file (but with crappy name), so we can use asterisk
23         mv *.love "${P}.zip" || die 'mv failed'
24         unpack "./${P}.zip"
25         rm "${P}.zip" || die 'rm failed'
26 }
27
28 src_prepare() {
29         default
30         # fix error on quit
31         sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
32 }
33
34 src_install() {
35         local dir="/usr/share/love/${PN}"
36         insinto "${dir}"
37         doins -r .
38         make_wrapper "${PN}" "love ${dir}"
39         make_desktop_entry "${PN}"
40 }