games-arcade/oshu: Fix tests
[gentoo.git] / games-arcade / methane / methane-1.5.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit desktop
6
7 DESCRIPTION="Port from an old amiga game"
8 HOMEPAGE="http://methane.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19 "
20
21 src_prepare() {
22         default
23
24         eapply "${FILESDIR}"/${P}-gentoo.patch
25
26         # From Fedora
27         eapply "${FILESDIR}"/${P}-gcc5.patch
28         eapply "${FILESDIR}"/${P}-fullscreen.patch
29
30         sed -i \
31                 -e "s:@GENTOO_DATADIR@:/usr/share:" \
32                 sources/target.cpp || die
33
34         # fix weird parallel make issue wrt #450422
35         mkdir build || die
36 }
37
38 src_install() {
39         dobin methane
40         insinto /usr/share/${PN}
41         doins resources/*
42         newicon docs/puff.gif ${PN}.gif
43         make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
44         HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
45 }