Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / games-arcade / betna / betna-0.9.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit eutils games
7
8 DESCRIPTION="Defend your volcano from the attacking ants by firing rocks/bullets at them"
9 HOMEPAGE="http://koti.mbnet.fi/makegho/c/betna/"
10 SRC_URI="http://koti.mbnet.fi/makegho/c/betna/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
15 IUSE=""
16
17 DEPEND="media-libs/libsdl[video]"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         sed -i \
22                 -e '/blobprintf.*char msg/s/char msg/const char msg/' \
23                 -e "s:images/:${GAMES_DATADIR}/${PN}/:" \
24                 src/main.cpp || die
25
26         sed -i \
27                 -e '/^LDFLAGS/d' \
28                 -e '/--libs/s/-o/$(LDFLAGS) -o/' \
29                 -e 's:-O2:$(CXXFLAGS):g' \
30                 -e 's/g++/$(CXX)/' \
31                 Makefile || die
32 }
33
34 src_compile() {
35         emake clean
36         emake
37 }
38
39 src_install() {
40         dogamesbin betna
41         insinto "${GAMES_DATADIR}"/${PN}
42         doins images/*
43         newicon images/target.bmp ${PN}.bmp
44         make_desktop_entry ${PN} Betna /usr/share/pixmaps/${PN}.bmp
45         dodoc README Q\&A
46         prepgamesdirs
47 }