proj/gentoo: Initial commit
[gentoo.git] / games-arcade / aquaria / aquaria-1.1.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit unpacker eutils games
7
8 DESCRIPTION="A 2D scroller set in a massive ocean world"
9 HOMEPAGE="http://www.bit-blot.com/aquaria/"
10 SRC_URI="aquaria-lnx-humble-bundle.mojo.run"
11
12 LICENSE="all-rights-reserved"
13 SLOT="0"
14 KEYWORDS="-* ~amd64 ~x86"
15 IUSE=""
16 RESTRICT="strip fetch bindist"
17
18 DEPEND="app-arch/unzip"
19 RDEPEND="
20         >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
21         >=media-libs/openal-1.15.1[abi_x86_32(-)]"
22
23 S=${WORKDIR}/data
24
25 pkg_nofetch() {
26         echo
27         elog "Download ${SRC_URI} from ${HOMEPAGE} and place it in ${DISTDIR}"
28         echo
29 }
30
31 src_unpack() {
32         unpack_zip ${A}
33 }
34
35 src_install() {
36         local dir="${GAMES_PREFIX_OPT}/${PN}"
37
38         insinto "${dir}"
39         exeinto "${dir}"
40
41         doins -r *.xml */
42         doexe "${PN}"
43         doicon "${PN}.png"
44
45         dodoc README-linux.txt
46         mv "${ED}/${dir}"/docs "${ED}/usr/share/doc/${PF}/html" || die
47         dosym /usr/share/doc/${PF}/html "${dir}"/docs
48
49         games_make_wrapper "${PN}" "./${PN}" "${dir}"
50         make_desktop_entry "${PN}" "Aquaria"
51
52         prepgamesdirs
53 }