sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathemat...
[gentoo.git] / games-action / xbomber / xbomber-101.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils games
7
8 DESCRIPTION="Bomberman clone w/multiplayer support"
9 HOMEPAGE="http://www.xdr.com/dash/bomber.html"
10 SRC_URI="http://www.xdr.com/dash/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE=""
16
17 DEPEND="x11-libs/libX11"
18 RDEPEND=${DEPEND}
19
20 src_prepare() {
21         sed -i \
22                 -e "/^CC/d" \
23                 -e 's/gcc/$(CC)/g' \
24                 -e "s:X386:X11R6:" \
25                 Makefile || die
26         sed -i \
27                 -e "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c || die
28         sed -i \
29                 -e "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c || die
30         epatch \
31                 "${FILESDIR}"/${P}-va_list.patch \
32                 "${FILESDIR}"/${P}-gcc4.patch \
33                 "${FILESDIR}"/${P}-ldflags.patch
34 }
35
36 src_install() {
37         dogamesbin matcher bomber
38         insinto "${GAMES_DATADIR}"/${PN}
39         doins -r data/*
40         dodoc README Changelog
41         prepgamesdirs
42 }