Drop $Id$ per council decision in bug #611234.
[gentoo.git] / games-action / xbomber / xbomber-101.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils games
6
7 DESCRIPTION="Bomberman clone w/multiplayer support"
8 HOMEPAGE="http://www.xdr.com/dash/bomber.html"
9 SRC_URI="http://www.xdr.com/dash/${P}.tgz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc x86"
14 IUSE=""
15
16 DEPEND="x11-libs/libX11"
17 RDEPEND=${DEPEND}
18
19 src_prepare() {
20         sed -i \
21                 -e "/^CC/d" \
22                 -e 's/gcc/$(CC)/g' \
23                 -e "s:X386:X11R6:" \
24                 Makefile || die
25         sed -i \
26                 -e "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c || die
27         sed -i \
28                 -e "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c || die
29         epatch \
30                 "${FILESDIR}"/${P}-va_list.patch \
31                 "${FILESDIR}"/${P}-gcc4.patch \
32                 "${FILESDIR}"/${P}-ldflags.patch
33 }
34
35 src_install() {
36         dogamesbin matcher bomber
37         insinto "${GAMES_DATADIR}"/${PN}
38         doins -r data/*
39         dodoc README Changelog
40         prepgamesdirs
41 }