dev-python/jaraco-collections: keyworded 3.0.0 for ia64, bug #717946
[gentoo.git] / games-action / trosh / trosh-20-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit desktop eutils gnome2-utils
7
8 DESCRIPTION="A game made in 20 hours for a friend. It has explosions"
9 HOMEPAGE="https://stabyourself.net/trosh/"
10 SRC_URI="https://stabyourself.net/dl.php?file=trosh/trosh-linux.zip -> ${P}.zip
11         https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
12
13 LICENSE="WTFPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="
18         >=games-engines/love-0.8.0:0
19          media-libs/devil[png]
20 "
21 DEPEND="app-arch/unzip"
22
23 S="${WORKDIR}"
24
25 src_install() {
26         local dir=/usr/share/love/${PN}
27
28         exeinto "${dir}"
29         doexe ${PN}.love
30
31         einstalldocs
32
33         doicon -s 32 "${DISTDIR}"/${PN}.png
34         make_wrapper ${PN} "love ${PN}.love" "${dir}"
35         make_desktop_entry ${PN}
36 }
37
38 pkg_preinst() {
39         gnome2_icon_savelist
40 }
41
42 pkg_postinst() {
43         gnome2_icon_cache_update
44 }
45
46 pkg_postrm() {
47         gnome2_icon_cache_update
48 }