Drop $Id$ per council decision in bug #611234.
[gentoo.git] / games-action / noiz2sa / noiz2sa-0.51a-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils user
6
7 DESCRIPTION="Abstract Shooting Game"
8 HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/noiz2sa_e.html https://sourceforge.net/projects/noiz2sa/"
9 SRC_URI="mirror://sourceforge/noiz2sa/${P}.tar.gz"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 DEPEND="
17         >=dev-libs/libbulletml-0.0.3
18         media-libs/sdl-mixer[vorbis]
19         virtual/opengl"
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/${PN}/src
23
24 PATCHES=(
25         "${FILESDIR}"/${P}-gcc41.patch
26         "${FILESDIR}"/${P}-underlink.patch
27 )
28
29 src_prepare(){
30         default
31         cp makefile.lin Makefile || die
32 }
33
34 src_install(){
35         local datadir="/usr/share/games/${PN}"
36
37         dobin ${PN}
38         dodir "${datadir}"
39         dodoc ../readme*
40
41         cp -r ../noiz2sa_share/* "${D}/${datadir}" || die
42 }