net-im/signal-desktop-bin: bump
[gentoo.git] / games-action / moon-buggy / moon-buggy-1.0.51-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools eutils user
6
7 DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
8 HOMEPAGE="http://www.seehuhn.de/comp/moon-buggy.html"
9 SRC_URI="http://www.seehuhn.de/data/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~x86"
14 IUSE=""
15
16 RDEPEND="sys-libs/ncurses:0"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 pkg_setup(){
21         enewgroup gamestat 36
22 }
23
24 src_prepare() {
25         default
26         sed -i \
27                 -e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
28                 Makefile.am || die
29         rm -f missing
30         eautoreconf
31 }
32
33 src_configure() {
34         econf \
35                 --sharedstatedir="/var/games" \
36                 --with-curses-libs="$(pkg-config ncurses --libs)"
37 }
38
39 src_install() {
40         default
41         touch "${D}/var/games/${PN}/mbscore"
42         fowners root:gamestat /usr/bin/${PN} /var/games/${PN} /var/games/${PN}/mbscore
43         fperms 2755 /usr/bin/${PN}
44         fperms 664 /var/games/${PN}/mbscore
45 }