Drop $Id$ per council decision in bug #611234.
[gentoo.git] / games-action / gltron / gltron-0.70-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils
6
7 DESCRIPTION="3d tron, just like the movie"
8 HOMEPAGE="http://gltron.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
10         mirror://gentoo/${PN}.png"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 DEPEND="
18         media-libs/libmikmod
19         media-libs/libpng:0
20         media-libs/libsdl[sound,video]
21         media-libs/sdl-mixer[vorbis]
22         media-libs/sdl-sound[vorbis,mikmod]
23         media-libs/smpeg
24         virtual/opengl"
25
26 RDEPEND=${DEPEND}
27
28 PATCHES=(
29         "${FILESDIR}"/${P}-configure.patch
30         "${FILESDIR}"/${P}-debian.patch
31         "${FILESDIR}"/${P}-gcc49.patch
32         "${FILESDIR}"/${P}-prototypes.patch
33 )
34
35 src_prepare() {
36         default
37         sed -i \
38                 -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
39                 Makefile.in || die
40 }
41
42 src_configure() {
43         # warn/debug/profile just modify CFLAGS, they aren't
44         # real options, so don't utilize USE flags here
45         econf \
46                 --disable-warn \
47                 --disable-debug \
48                 --disable-profile
49 }
50
51 src_install() {
52         default
53         doicon "${DISTDIR}"/${PN}.png
54         make_desktop_entry ${PN} GLtron
55 }