Drop $Id$ per council decision in bug #611234.
[gentoo.git] / games-action / gltron / gltron-0.70-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils games
6
7 DESCRIPTION="3d tron, just like the movie"
8 HOMEPAGE="http://gltron.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
10         mirror://gentoo/${PN}.png"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 DEPEND="virtual/opengl
18         media-libs/libpng:0
19         media-libs/libsdl[sound,video]
20         media-libs/sdl-mixer[vorbis]
21         media-libs/sdl-sound[vorbis,mikmod]
22         media-libs/smpeg
23         media-libs/libmikmod"
24 RDEPEND=${DEPEND}
25
26 src_prepare() {
27         epatch \
28                 "${FILESDIR}"/${P}-configure.patch \
29                 "${FILESDIR}"/${P}-prototypes.patch \
30                 "${FILESDIR}"/${P}-debian.patch \
31                 "${FILESDIR}"/${P}-gcc49.patch
32         sed -i \
33                 -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
34                 Makefile.in || die
35 }
36
37 src_configure() {
38         # warn/debug/profile just modify CFLAGS, they aren't
39         # real options, so don't utilize USE flags here
40         egamesconf \
41                 --disable-warn \
42                 --disable-debug \
43                 --disable-profile
44 }
45
46 src_install() {
47         default
48         doicon "${DISTDIR}"/${PN}.png
49         make_desktop_entry ${PN} GLtron
50         prepgamesdirs
51 }