dev-libs/tomsfastmath: keyworded 0.13.1 for ia64, bug #725414
[gentoo.git] / games-action / descent1-demodata / descent1-demodata-1.4-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit unpacker
7
8 DEMO="desc${PV//.}sw.exe"
9
10 DESCRIPTION="Demo data files for Descent 1"
11 HOMEPAGE="http://www.interplay.com/games/descent.php"
12 SRC_URI="http://icculus.org/d2x/data/${DEMO}
13         ftp://ftp.funet.fi/pub/msdos/games/interplay/${DEMO}"
14 LICENSE="free-noncomm"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 RDEPEND="!games-action/descent1-data"
19
20 DEPEND="app-arch/unzip
21         app-arch/unarj"
22
23 S="${WORKDIR}"
24
25 src_unpack() {
26         unpack_zip ${A}
27
28         unarj e DESCENT1.SOW || die
29         mv descent.pig{,1} || die
30         unarj e DESCENT2.SOW || die
31         mv descent.pig{,2} || die
32
33         # From the sows, big porkie pies shall grow
34         cat descent.pig{1,2} > descent.pig || die
35 }
36
37 src_install() {
38         insinto /usr/share/games/d1x
39         doins descent.{hog,pig}
40         dodoc *.txt
41 }
42
43 pkg_postinst() {
44         elog "A client is needed to run the game, e.g. games-action/dxx-rebirth."
45         echo
46 }