dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / games-action / crimsonland / crimsonland-1.3.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils desktop xdg-utils
7
8 DESCRIPTION="A top-down shooter with a touch of RPG"
9 HOMEPAGE="https://crimsonland.com/"
10 SRC_URI="Crimsonland-Linux-x86-${PV}.tar"
11 #       https://dev.gentoo.org/~chewi/distfiles/${PN}.png"
12 LICENSE="all-rights-reserved"
13 SLOT="0"
14 KEYWORDS="-* ~amd64 ~x86"
15 RESTRICT="bindist fetch splitdebug"
16
17 RDEPEND="
18         media-libs/libsdl2[abi_x86_32,opengl,video]
19         media-libs/openal[abi_x86_32]
20 "
21
22 S="${WORKDIR}"
23
24 DIR="/opt/${PN}"
25 QA_PREBUILT="${DIR}/*"
26
27 pkg_nofetch() {
28         einfo "Please buy and download ${SRC_URI} from:"
29         einfo "  https://www.humblebundle.com/store/${PN}"
30         einfo "and move it to your distfiles directory."
31 }
32
33 src_install() {
34         exeinto "${DIR}"
35         doexe ${PN}
36         make_wrapper ${PN} ./${PN} "${DIR}"
37
38         insinto "${DIR}"
39         doins *.pak *.xml
40
41         dodoc README.txt
42
43 #       doicon -s 64 "${DISTDIR}"/${PN}.png
44         make_desktop_entry ${PN} Crimsonland applications-games
45 }
46
47 pkg_postinst() { xdg_icon_cache_update; }
48 pkg_postrm() { xdg_icon_cache_update; }