Use lbzip2 for tar.bz2
[catalyst.git] / examples / grp_template.spec
1 # generic GRP (Gentoo Reference Platform) specfile
2 # used to build a GRP set
3
4 # The subarch can be any of the supported catalyst subarches (like athlon-xp).
5 # Refer to "man catalyst" or <http://www.gentoo.org/proj/en/releng/catalyst/>
6 # for supported subarches
7 # example:
8 # subarch: athlon-xp
9 subarch:
10
11 # The version stamp is an identifier for the build.  It can be anything you wish# it to be, but it is usually a date.
12 # example:
13 # version_stamp: 2006.1
14 version_stamp:
15
16 # The target specifies what target we want catalyst to do. For GRP, the
17 # supported targets are: grp
18 # example:
19 # target: grp
20 target: grp 
21
22 # The rel_type defines what kind of build we are doing.  This is merely another
23 # identifier, but it useful for allowing multiple concurrent builds.  Usually,
24 # default will suffice.
25 # example:
26 # rel_type: default
27 rel_type:
28
29 # This is the system profile to be used by catalyst to build this target.  It is# specified as a relative path from /usr/portage/profiles.
30 # example:
31 # profile: default-linux/x86/2006.1
32 profile:
33
34 # This specifies which snapshot to use for building this target.
35 # example:
36 # snapshot: 2006.1
37 snapshot:
38
39 # This specifies where the seed stage comes from for this target,  The path is
40 # relative to $clst_sharedir/builds.  The rel_type is also used as a path prefix# for the seed.
41 # example:
42 # default/stage3-x86-2006.1
43 source_subpath:
44
45 # These are the hosts used as distcc slaves when distcc is enabled in your
46 # catalyst.conf.  It follows the same syntax as distcc-config --set-hosts and
47 # is entirely optional.
48 # example:
49 # distcc_hosts: 127.0.0.1 192.168.0.1
50 distcc_hosts:
51
52 # This is an optional directory containing portage configuration files.  It
53 # follows the same syntax as /etc/portage and should be consistent across all
54 # targets to minimize problems.
55 # example:
56 # portage_confdir: /etc/portage
57 portage_confdir:
58
59 # This option specifies the location to a portage overlay that you would like to
60 # have used when building this target.
61 # example:
62 # portage_overlay: /usr/local/portage
63 portage_overlay:
64
65 # This allows the optional directory containing the output packages for
66 # catalyst.  Mainly used as a way for different spec files to access the same
67 # cache directory.  Default behavior is for this location to be autogenerated
68 # by catalyst based on the spec file.
69 # example:
70 # pkgcache_path: /tmp/packages
71 pkgcache_path:
72
73 # Since GRP is capable of building packages/source sets for more than one CD,
74 # this defines the layout for the directories under $clst_sharedir/builds.
75 # example:
76 # grp: src cd2
77 grp: src cd2
78
79 # GRP is also able to build packages with customized USE settings.  However, it
80 # is very possible to cause quite a few problems with these, so be careful with
81 # whatever USE flags you add here.  This is generally used for adding some
82 # functionality that we do not want on by default for all Gentoo users, but that
83 # we want on by default in our binaries.  Some examples would be things like the
84 # socks5 USE flag.
85 # example:
86 # grp/use: gtk2 gnome kde qt bonobo cdr esd gtkhtml mozilla mysql perl ruby tcltk cups ldap ssl tcpd -svga
87 grp/use:
88
89 # This tells catalyst what type of GRP set this list of packages will create.
90 # Valid options here are srcset or pkgset to either download the source, or to
91 # build packages, respectively.
92 # example:
93 # grp/src/type: srcset
94 grp/src/type:
95
96 # Since this is a srcset, these ebuilds will have their distfiles fetched and
97 # the distfiles will be stored in the src directory under $clst_sharedir/builds.
98 # Packages will not be made out of this list.  We use this for grabbing things
99 # that need a compiled kernel to build, or things listed in the Handbook that
100 # should be available before the first reboot during an install.
101 # example:
102 # grp/src/packages: gentoo-sources udev vanilla-sources rp-pppoe speedtouch fcdsl fritzcapi globespan-adsl pptpclient slmodem lvm2 evms iputils vixie-cron fcron dcron sysklogd metalog syslog-ng raidtools jfsutils xfsprogs reiserfsprogs dosfstools ntfsprogs lilo grub isdn4k-utils iproute2 wireless-tools wpa_supplicant pcmcia-cs hotplug coldplug dhcpcd slocate genkernel ipw2100 ipw2200 fxload logrotate
103 grp/src/packages:
104
105 # This is mostly here for completeness.  This is the pkgset definition.
106 # example:
107 # grp/cd2/type: pkgset
108 grp/cd2/type:
109
110 # This is our list of packages that will comprise our package set.  These are
111 # fetched, compiled, and the packages are stored under $clst_sharedir/builds.
112 # example:
113 # grp/cd2/packages: dante tsocks sys-apps/eject minicom links acpid apmd parted whois tcpdump cvs zip unzip netcat partimage app-admin/sudo app-cdr/cdrtools gnome emacs dev-lang/ruby enlightenment kde mozilla-firefox mozilla-thunderbird xfce4 openbox fluxbox sylpheed openoffice-bin gimp xemacs xmms abiword gaim xchat pan tetex xcdroast k3b samba nmap gradm ettercap ethereal mplayer
114 grp/cd2/packages: