Fixing typo in snapshot_template.spec and closing bug #70321.
[catalyst.git] / examples / grp_template.spec
1 ## generic GRP (Gentoo Reference Platform) specfile
2 ## used to build a GRP set
3
4 ## John Davis <zhen@gentoo.org>
5
6 # subarch can be any of the supported Catalyst subarches (like athlon-xp). Refer
7 # to the catalyst reference manual (http://www.gentoo.org/proj/en/releng/catalyst) for supported arches.
8 # example:
9 # subarch: athlon-xp
10 subarch:
11
12 # version stamp is an identifier for the build. can be anything you want it to be, but it
13 # is usually a date.
14 # example:
15 # version_stamp: 2004.2
16 version_stamp: 
17
18 # target specifies what type of build Catalyst is to do. check the catalyst reference manual
19 # for supported targets.
20 # example:
21 # target: grp
22 target: grp 
23
24 # rel_type defines what kind of build we are doing. usually, default will suffice.
25 # example:
26 # rel_type: default
27 rel_type:
28
29 # system profile used to build the media
30 # example:
31 # profile: default-x86-2004.0
32 profile:
33
34 # which snapshot to use
35 # example:
36 # snapshot: 20040614
37 snapshot:
38
39 # where the seed stage comes from, path is relative to $clst_sharedir (catalyst.conf)
40 # example:
41 # default/stage3-x86-2004.1
42
43 # directories to organize the GRP into
44 grp: src cd2
45
46 # use variables to use when building the GRP set
47 grp/use: 
48         gtk2 
49         gnome 
50         kde 
51         qt 
52         bonobo 
53         cdr 
54         esd 
55         gtkhtml 
56         mozilla
57         mysql
58         perl
59         ruby
60         tcltk
61         acl
62         cups
63         ldap
64         ssl
65         tcpd
66         -svga
67
68 # okay, two things here. first, we know we are building stuff to go into the "src" directory
69 # because of the grp/src line (first part before the / is the build type, second part is
70 # directory specified in the grp: key). It is identified as a "srcset" which means that these
71 # packages will be *fetched only* and not compiled.
72 grp/src/type: srcset
73 grp/src/packages:
74         gentoo-sources
75         gentoo-dev-sources
76         vanilla-sources
77         development-sources
78         iptables
79         gpm
80         rp-pppoe
81         ppp
82         speedtouch
83         pciutils
84         hdparm
85         hotplug
86         aumix
87         xfree
88         iputils
89         vixie-cron
90         sysklogd
91         metalog
92         syslog-ng
93         raidtools
94         jfsutils
95         xfsprogs
96         reiserfsprogs
97         lvm-user
98         dosfstools
99         lilo
100         grub
101         superadduser
102         gentoolkit
103         chkrootkit
104         minicom
105         lynx
106         rpm2targz
107         parted
108         rdate
109         whois
110         tcpdump
111         cvs
112         unzip
113         zip
114         netcat
115         isdn4k-utils
116         nforce-net
117         nforce-audio
118         iproute
119         nvidia-kernel
120         nvidia-glx
121         ati-drivers
122         e100
123         e1000
124         wireless-tools
125         pcmcia-cs
126         emu10k1
127         evms
128         linux-wlan-ng
129         sys-apps/eject
130         genkernel
131
132 # same as above, but this time we have a "pkgset". this means that we will fetch and compile
133 # the desired package
134 grp/cd2/type: pkgset
135 grp/cd2/packages:
136         pciutils
137         hdparm
138         hotplug
139         aumix
140         xfree
141         dante
142         tsocks
143         chkrootkit
144         minicom
145         lynx
146         rpm2targz
147         parted
148         rdate
149         whois
150         tcpdump
151         cvs
152         unzip
153         zip
154         netcat
155         partimage
156         DirectFB
157         apache
158         app-cdr/cdrtools
159         gnome
160         evolution
161         cups
162         dev-db/mysql
163         dev-lang/ruby
164         emacs
165         enlightenment
166         fluxbox
167         kde
168         libsdl
169         mozilla
170         xfce4
171         openbox
172         openoffice
173         sylpheed
174         vim
175         xemacs
176         xmms
177         mozilla-firefox
178         abiword
179         gaim
180         tetex
181         xcdroast
182         samba
183         nmap
184         gradm
185         ettercap
186         xchat
187         dante
188         tsocks