media-libs/imlib2: arm stable wrt bug #669940
[gentoo.git] / dev-vcs / svn2git / svn2git-1.0.13.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit desktop qmake-utils
7 [[ "${PV}" == "9999" ]] && inherit git-r3
8
9 DESCRIPTION="Tool for one-time conversion from svn to git"
10 HOMEPAGE="https://github.com/svn-all-fast-export/svn2git"
11 if [[ "${PV}" == "9999" ]]; then
12         EGIT_REPO_URI="https://github.com/svn-all-fast-export/svn2git.git"
13 else
14         SRC_URI="https://github.com/svn-all-fast-export/svn2git/archive/${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 IUSE=""
21 # KEYWORDS way up
22
23 DEPEND="
24         dev-qt/qtcore:5
25         dev-vcs/subversion"
26 RDEPEND="${DEPEND}
27         dev-vcs/git"
28
29 DOCS=( README.md )
30
31 src_configure() {
32         local qmake_args=(
33                 APR_INCLUDE=/usr/include/apr-1
34                 PREFIX=/usr
35                 SVN_INCLUDE=/usr/include/subversion-1
36                 VERSION=${PV}
37         )
38         eqmake5 "${qmake_args[@]}" fast-export2.pro
39 }
40
41 src_install() {
42         einstalldocs
43         insinto /usr/share/${PN}/samples
44         doins samples/*.rules || die 'doins failed'
45         dobin svn-all-fast-export || die 'dobin failed'
46         dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
47 }