dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-vcs / repo / repo-2.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 # NB: The $PV tracks the *repo launcher version*, not the last signed release
5 # of the repo project.  The launcher only gets a new update when changes are
6 # made in it.
7
8 EAPI="7"
9
10 PYTHON_COMPAT=( python3_{6..8} )
11
12 inherit python-r1
13
14 DESCRIPTION="Google tool for managing git, particularly multiple repos"
15 HOMEPAGE="https://gerrit.googlesource.com/git-repo"
16 SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
17
18 LICENSE="Apache-2.0"
19 SLOT="0"
20 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
21 IUSE=""
22 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
23
24 RDEPEND="${PYTHON_DEPS}
25         !app-admin/radmind
26         !dev-util/repo"
27
28 S=${WORKDIR}
29
30 src_install() {
31         python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
32 }