f2e793147ad551effecef832d5a687e6f24ded6c
[gentoo.git] / dev-vcs / repo / repo-1.26.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 # NB: The $PV tracks the *repo launcher version*, not the last signed release
5 # of the repo project.  They are confusingly different currently.
6
7 EAPI="7"
8
9 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
10
11 inherit python-r1
12
13 DESCRIPTION="Google tool for managing git, particularly multiple repos"
14 HOMEPAGE="https://gerrit.googlesource.com/git-repo"
15 SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
16
17 LICENSE="Apache-2.0"
18 SLOT="0"
19 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sh ~sparc x86"
20 IUSE=""
21 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
22
23 RDEPEND="${PYTHON_DEPS}
24         !app-admin/radmind
25         !dev-util/repo"
26
27 S=${WORKDIR}
28
29 src_install() {
30         python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
31 }