sys-apps/gawk: stable 5.0.1 for ppc, bug #725374
[gentoo.git] / dev-vcs / python-gitlab / python-gitlab-1.13.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 )
6
7 if [[ ${PV} = *9999* ]]; then
8         EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
9         inherit git-r3
10 else
11         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12         KEYWORDS="~amd64"
13 fi
14
15 inherit distutils-r1
16
17 DESCRIPTION="Python command line interface to gitlab API"
18 HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
19
20 LICENSE="LGPL-3"
21 SLOT="0"
22 IUSE="test"
23 RESTRICT="!test? ( test )"
24
25 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? (
27                 dev-python/testrepository[${PYTHON_USEDEP}]
28                 dev-python/hacking[${PYTHON_USEDEP}]
29                 dev-python/httmock[${PYTHON_USEDEP}]
30                 dev-python/jinja[${PYTHON_USEDEP}]
31                 dev-python/mock[${PYTHON_USEDEP}]
32                 >=dev-python/sphinx-1.3
33                 dev-python/sphinx_rtd_theme )"
34
35 RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
36         dev-python/setuptools[${PYTHON_USEDEP}]
37         dev-python/six[${PYTHON_USEDEP}]"
38
39 python_install_all() {
40         distutils-r1_python_install_all
41         dodoc -r *.rst docs
42 }