Merge remote-tracking branch 'remotes/sbraz/pysrt'
[gentoo.git] / dev-vcs / hg-git / hg-git-0.8.5.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="push to and pull from a Git repository using Mercurial"
11 HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE=""
18
19 RDEPEND="
20         >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
21         >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25 "