Use https by default
[gentoo.git] / dev-vcs / gitstats / gitstats-0_pre131024.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit python-r1
10
11 DESCRIPTION="Statistics generator for git"
12 HOMEPAGE="http://gitstats.sourceforge.net/"
13 SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         sci-visualization/gnuplot[gd]
22         dev-vcs/git"
23 DEPEND=""
24
25 src_prepare() {
26         sed \
27                 -e "s:basedir = os.path.dirname(os.path.abspath(__file__)):basedir = '${EPREFIX}/usr/share/gitstats':g" \
28                 -i gitstats || die "failed to fix static files path"
29 }
30
31 src_compile() {
32         :;
33 }
34
35 src_install() {
36         emake PREFIX="${D}"/usr VERSION="${PV}" install
37         dodoc doc/{README,*.txt}
38         python_replicate_script "${ED}"/usr/bin/${PN}
39 }