app-shells/bash: stable 5.0_p17 for hppa, bug #719942
[gentoo.git] / dev-vcs / git-remote-hg / git-remote-hg-1.0.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Semi-official Mercurial bridge from Git project"
10 HOMEPAGE="https://github.com/mnauw/git-remote-hg"
11 SRC_URI="https://github.com/mnauw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 BDEPEND="
18         app-text/asciidoc
19 "
20 RDEPEND="
21         dev-vcs/git
22         dev-vcs/mercurial
23 "
24
25 # Some tests fail.
26 RESTRICT="test"
27
28 src_compile() {
29         distutils-r1_src_compile
30         emake doc
31 }
32
33 src_install() {
34         distutils-r1_src_install
35         emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-doc
36 }
37
38 src_test() {
39         default
40 }