dev-qt/qtwayland: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-vcs / git-deps / git-deps-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGIT_REPO_URI="https://github.com/aspiers/git-deps"
7 EGIT_BRANCH=master
8
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit eutils git-r3 python-single-r1
12
13 DESCRIPTION="git commit dependency analysis tool"
14 HOMEPAGE="https://github.com/aspiers/git-deps"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18
19 RDEPEND="
20         $(python_gen_cond_dep '
21                 dev-python/flask[${PYTHON_MULTI_USEDEP}]
22                 dev-python/pygit2[${PYTHON_MULTI_USEDEP}]
23         ')
24         net-libs/nodejs
25         ${PYTHON_DEPS}
26         "
27 DEPEND="${RDEPEND}"
28 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
29
30 HTML_DOCS="html/."
31
32 pkg_setup() {
33         python-single-r1_pkg_setup
34 }
35
36 src_install() {
37         python_newscript git-deps.py git-deps
38         einstalldocs
39 }
40
41 pkg_postinst() {
42         elog "Notes regarding the '--serve' option:"
43         elog "Please run 'npm install browserify' once"
44         elog "Copy the html sources:"
45         elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
46         elog "cd ~/git-deps-html"
47         elog "npm install"
48         elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
49 }