Use https by default
[gentoo.git] / dev-vcs / git-bzr-ng / git-bzr-ng-0_pre20120822.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 PYTHON_DEPEND="2"
8
9 inherit python
10
11 DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
12 HOMEPAGE="https://github.com/termie/git-bzr-ng"
13 SRC_URI="https://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18 IUSE=""
19
20 RDEPEND=">=dev-vcs/bzr-2.2
21         dev-vcs/git
22         >=dev-vcs/bzr-fastimport-0.10
23         dev-python/python-fastimport"
24 DEPEND="app-arch/xz-utils"
25
26 pkg_setup() {
27         python_set_active_version 2
28         python_pkg_setup
29 }
30
31 src_prepare() {
32         python_convert_shebangs 2 git-bzr
33 }
34
35 src_install() {
36         exeinto /usr/libexec/git-core
37         doexe git-bzr
38         dodoc README.rst
39 }