x11-misc/sddm: merge remote-tracking branch 'a17r/sddm'
[gentoo.git] / dev-vcs / cvs2svn / cvs2svn-2.4.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6 PYTHON_DEPEND="2"
7 PYTHON_USE_WITH_OR="berkdb gdbm"
8 PYTHON_USE_WITH_OPT="test"
9 SUPPORT_PYTHON_ABIS="1"
10 RESTRICT_PYTHON_ABIS="3.* *-jython"
11
12 inherit distutils
13
14 FILEVER="49237"
15
16 DESCRIPTION="Convert a CVS repository to a Subversion repository"
17 HOMEPAGE="http://cvs2svn.tigris.org/"
18 SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
19
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
23 IUSE="bazaar git test"
24
25 DEPEND=">=dev-vcs/subversion-1.0.9"
26 RDEPEND="${DEPEND}
27         bazaar? ( >=dev-vcs/bzr-1.13 )
28         git? ( >=dev-vcs/git-1.5.4.4 )
29         dev-vcs/rcs"
30
31 PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
32
33 src_prepare() {
34         distutils_src_prepare
35         python_convert_shebangs -r 2 .
36 }
37
38 src_compile() {
39         distutils_src_compile
40         emake man
41 }
42
43 src_install() {
44         distutils_src_install
45         insinto "/usr/share/${PN}"
46         doins -r contrib cvs2{svn,git,bzr}-example.options
47         doman *.1
48 }
49
50 src_test() {
51         # Need this because subversion is localized, but the tests aren't
52         export LC_ALL=C
53
54         testing() {
55                 "$(PYTHON)" -W ignore run-tests.py
56         }
57         python_execute_function testing
58 }
59
60 pkg_postinst() {
61         distutils_pkg_postinst
62         elog "Additional scripts and examples have been installed to:"
63         elog "  /usr/share/${PN}/"
64 }