Use https by default
[gentoo.git] / dev-vcs / colorcvs / colorcvs-1.4-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=3
6
7 inherit eutils prefix
8
9 DESCRIPTION="A tool based on colorgcc to beautify cvs output"
10 HOMEPAGE="http://packages.gentoo.org/package/dev-vcs/colorcvs"
11 SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="
20         dev-lang/perl
21         dev-vcs/cvs"
22
23 src_prepare() {
24         # fix typo
25         sed -i -e 's:compiler_pid:cvs_pid:' ${PN} || die "sed failed"
26         epatch "${FILESDIR}"/${P}-prefix.patch
27         eprefixify colorcvs
28 }
29
30 src_install() {
31         insinto /etc/profile.d
32         doins "${FILESDIR}/${PN}-profile.sh" || die "doins failed"
33
34         dobin colorcvs || die "dobin failed"
35         dodoc colorcvsrc-sample || die "dodoc failed"
36 }
37
38 pkg_postinst() {
39         echo
40         einfo "An alias to colorcvs was installed for the cvs command."
41         einfo "In order to immediately activate it do:"
42         einfo "\tsource /etc/profile"
43         echo
44 }