dev-util/xxdiff: use 'dodoc'
[gentoo.git] / dev-util / xxdiff / xxdiff-4.0.1_p20170622.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1 qmake-utils
9
10 DESCRIPTION="A graphical file and directories comparator and merge tool"
11 HOMEPAGE="http://furius.ca/xxdiff/"
12 # generated as 'hg archive xxdiff-${P}.tar'
13 # from https://bitbucket.org/blais/xxdiff tree
14 #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
15 SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.bz2"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="amd64 x86"
20 IUSE=""
21
22 RDEPEND="
23         dev-qt/qtcore:5
24         dev-qt/qtgui:5
25         dev-qt/qtwidgets:5
26 "
27 DEPEND="
28         ${RDEPEND}
29         virtual/yacc
30 "
31
32 PATCHES=(
33         "${FILESDIR}"/${PN}-4.0.1-no-throw-in-dtor.patch
34         "${FILESDIR}"/${P}-cxx11.patch
35 )
36
37 src_configure() {
38         pushd src >/dev/null || die
39                 # mimic src/Makefile.bootstrap
40                 eqmake5
41                 cat Makefile.extra >> Makefile || die
42         popd
43
44         distutils-r1_src_configure
45 }
46
47 src_compile() {
48         emake -C src MAKEDIR=.
49
50         distutils-r1_src_compile
51         HTML_DOCS+=(
52                 doc/*.{png,html}
53                 src/doc.html
54         )
55 }
56
57 src_install() {
58         dobin bin/xxdiff
59
60         distutils-r1_src_install
61
62         dodoc CHANGES README* TODO doc/*.txt src/doc.txt
63
64         # example tools, use these to build your own ones
65         dodoc -r tools
66 }