dev-util/drone-cli: Drop to maintainer-needed
[gentoo.git] / dev-util / waf / waf-1.9.14.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
7 PYTHON_REQ_USE="threads(+)"
8 inherit python-any-r1 toolchain-funcs
9
10 DESCRIPTION="piece of software used to help building software projects"
11 HOMEPAGE="https://waf.io/"
12 SRC_URI="https://waf.io/${P}.tar.bz2"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="examples"
18
19 DEPEND="${PYTHON_DEPS}"
20
21 DOCS="ChangeLog README.md DEVEL"
22
23 src_prepare() {
24         rm -v waf || die
25
26         default
27 }
28
29 src_configure() {
30         ${EPYTHON} ./waf-light configure
31 }
32
33 src_compile() {
34         ${EPYTHON} ./waf-light build
35 }
36
37 src_install() {
38         default
39
40         #point waf binary to waflib dir and strip payload
41         sed -e "/INSTALL=/s:=.*:='${EROOT}usr':" \
42                 -e "/REVISION=/s:=.*:='${PR}':" \
43                 -e "s:/lib/:/$(get_libdir)/:" \
44                 -e "/^#\(==>\|BZ\|<==\)/d" \
45                 -i waf || die
46         dobin waf
47
48         insinto /usr/$(get_libdir)/${PN}3-${PV}-${PR}
49         doins -r waflib
50
51         if use examples ; then
52                 dodoc -r demos
53         fi
54 }