dev-util/vulkan-tools: Bump to 1.1.77.0
[gentoo.git] / dev-util / vulkan-tools / vulkan-tools-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{4,5,6} )
6
7 if [[ "${PV}" == "9999" ]]; then
8         EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Tools.git"
9         EGIT_SUBMODULES=()
10         inherit git-r3
11 else
12         EGIT_COMMIT="384fff68c802a10b5d7f4f352a4bb43b3efe5f23"
13         KEYWORDS="~amd64"
14         SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
15         S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
16 fi
17
18 inherit python-any-r1 cmake-multilib
19
20 DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
21 HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
22
23 LICENSE="Apache-2.0"
24 SLOT="0"
25 IUSE="X wayland"
26
27 # Old packaging will cause file collisions
28 RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"
29 DEPEND="${PYTHON_DEPS}
30         dev-util/glslang:=[${MULTILIB_USEDEP}]
31         dev-util/vulkan-headers
32         media-libs/vulkan-loader:=[${MULTILIB_USEDEP},wayland?,X?]
33         wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
34         X? (
35                 x11-libs/libX11:=[${MULTILIB_USEDEP}]
36                 x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
37            )"
38
39 multilib_src_configure() {
40         local mycmakeargs=(
41                 -DCMAKE_SKIP_RPATH=True
42                 -DBUILD_WSI_MIR_SUPPORT=False
43                 -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
44                 -DBUILD_WSI_XCB_SUPPORT=$(usex X)
45                 -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
46                 -DGLSLANG_INSTALL_DIR="/usr"
47                 -DVULKAN_HEADERS_INSTALL_DIR="/usr"
48         )
49         cmake-utils_src_configure
50 }