www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-util / visual-regexp / visual-regexp-3.0-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="Type the regexp and visualize it on a sample of your choice"
9 HOMEPAGE="http://laurent.riesterer.free.fr/regexp/"
10 SRC_URI="
11         https://dev.gentoo.org/~jlec/distfiles/visualregexp-icon.png.tar
12         http://laurent.riesterer.free.fr/regexp/visual_regexp-${PV}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND=">=dev-lang/tk-8.3"
21
22 S=${WORKDIR}/visual_regexp-${PV}
23
24 src_prepare() {
25         epatch \
26                 "${FILESDIR}"/${P}-wish-fix.patch \
27                 "${FILESDIR}"/${P}-help-font-fix.patch \
28                 "${FILESDIR}"/${P}-home-conf-fix.patch \
29                 "${FILESDIR}"/${P}-pattern-load-fix.patch
30 }
31
32 src_install() {
33         dodoc README
34
35         newbin visual_regexp.tcl visualregexp
36
37         dosym visualregexp /usr/bin/tkregexp
38
39         doicon "${WORKDIR}"/visualregexp-icon.png
40
41         domenu "${FILESDIR}"/visualregexp.desktop
42 }