Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-util / uncrustify / uncrustify-0.61.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6
7 inherit eutils
8
9 DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
10 HOMEPAGE="http://uncrustify.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
16 IUSE="test"
17
18 DEPEND="test? ( =dev-lang/python-2* )"
19 RDEPEND=""
20
21 src_test() {
22         cd tests
23         python2 run_tests.py || die "tests failed"
24 }
25
26 src_install() {
27         emake DESTDIR="${D}" install || die "Install failed"
28         dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
29 }