Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / dev-util / uncrustify / uncrustify-0.61-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ $PV == *9999* ]]; then
8         EGIT_REPO_URI="git://github.com/bengardner/uncrustify.git
9                 https://github.com/bengardner/uncrustify.git"
10         KEYWORDS=""
11         SRC_URI=""
12         inherit git-r3
13 else
14         KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
15         SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
16 fi
17
18 PYTHON_COMPAT=( python2_7 )
19
20 inherit python-any-r1
21
22 DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
23 HOMEPAGE="http://uncrustify.sourceforge.net/"
24
25 LICENSE="GPL-2"
26 SLOT="0"
27 IUSE="test"
28
29 DEPEND="test? ( ${PYTHON_DEPS} )"
30
31 python_test() {
32         cd tests
33         ${EPYTHON} run_tests.py || die "tests failed"
34 }