dev-util/squashmerge: Bump to EAPI 7
[gentoo.git] / dev-util / squashmerge / squashmerge-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
7 inherit autotools git-r3
8
9 DESCRIPTION="dev-util/squashdelta delta merge tool"
10 HOMEPAGE="https://github.com/mgorny/squashmerge/"
11 SRC_URI=""
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="lz4 +lzo"
17 # SquashDelta does not make much sense without a compression algo.
18 REQUIRED_USE="|| ( lz4 lzo )"
19
20 COMMON_DEPEND="
21         lz4? ( app-arch/lz4:0= )
22         lzo? ( dev-libs/lzo:2= )"
23 RDEPEND="${COMMON_DEPEND}
24         dev-util/xdelta:3"
25 DEPEND=${COMMON_DEPEND}
26
27 DOCS=( FORMAT )
28
29 src_prepare() {
30         default
31         eautoreconf
32 }
33
34 src_configure() {
35         local myconf=(
36                 $(use_enable lz4)
37                 $(use_enable lzo)
38         )
39
40         econf "${myconf[@]}"
41 }