dev-util/radare2: bump up to 3.5.1
[gentoo.git] / dev-util / spirv-tools / spirv-tools-2018.4.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-multilib cmake-utils
7
8 DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
9 HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
10 SRC_URI="https://github.com/KhronosGroup/SPIRV-Tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 # Tests fail upon finding symbols that do not match a regular expression
16 # in the generated library. Easily hit with non-standard compiler flags
17 RESTRICT="test"
18
19 RDEPEND=""
20 DEPEND=">=dev-util/spirv-headers-1.3.1_pre20180710"
21 EGIT_COMMIT="f508896d6487d09f5c9a2a3835595446fec0791a"
22 S="${WORKDIR}/SPIRV-Tools-${PV}"
23
24 multilib_src_configure() {
25         local mycmakeargs=(
26                 "-DSPIRV-Headers_SOURCE_DIR=/usr/"
27                 "-DSPIRV_WERROR=OFF"
28         )
29
30         cmake-utils_src_configure
31 }
32
33 multilib_src_install() {
34         cmake-utils_src_install
35         echo "${EGIT_COMMIT}" > "${PN}-commit.h" || die
36         insinto /usr/include/"${PN}"
37         doins  "${PN}-commit.h"
38 }