Use https by default
[gentoo.git] / dev-util / shellcheck / shellcheck-0.3.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
8
9 inherit haskell-cabal
10
11 MY_PN="ShellCheck"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Shell script analysis tool"
15 HOMEPAGE="http://www.shellcheck.net/"
16 SRC_URI="
17         mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
18 #       https://dev.gentoo.org/~mjo/distfiles/${PN}-man-${PV}.tar.xz"
19
20 LICENSE="AGPL-3"
21 SLOT="0/${PV}"
22 KEYWORDS="~amd64 ~x86"
23 IUSE=""
24
25 RDEPEND="
26         dev-haskell/json:=[profile?]
27         dev-haskell/mtl:=[profile?]
28         dev-haskell/parsec:=[profile?]
29         >=dev-haskell/quickcheck-2.7.4:2=[profile?]
30         dev-haskell/regex-compat:=[profile?]
31         dev-haskell/transformers:=[profile?]
32         >=dev-lang/ghc-7.8.4:=
33 "
34 DEPEND="${RDEPEND}
35         >=dev-haskell/cabal-1.8
36 "
37
38 S="${WORKDIR}/${MY_P}"
39
40 src_test() {
41         # See bug #537500 for this beauty.
42         runghc Setup.hs test || die 'test suite failed'
43 }
44
45 src_install() {
46         cabal_src_install
47         doman "${PN}.1"
48 }