dev-util/sel: amd64 stable wrt bug #647518
[gentoo.git] / dev-util / sel / sel-0.08.4-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A filemanager for shell scripts"
9 SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
10 HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="amd64 ~ppc ~s390 ~sparc ~x86"
15
16 RDEPEND="sys-libs/ncurses:0="
17
18 DOCS=( "help.txt" README.GER whatsnew )
19
20 src_prepare () {
21         default
22         sed -i \
23                 -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
24                 "${PN}.c" || die 'sed failed'
25 }
26
27 src_compile() {
28         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
29 }
30
31 src_install () {
32         dobin "${PN}"
33         doman "${PN}.1"
34         einstalldocs
35 }