dev-util/meson: sh/m68k stable wrt bug #656920
[gentoo.git] / dev-util / scanmem / scanmem-0.16.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
6
7 inherit autotools eutils python-single-r1
8
9 DESCRIPTION="Locate and modify variables in executing processes"
10 HOMEPAGE="https://github.com/scanmem/scanmem"
11 SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="gui"
17
18 DEPEND="sys-libs/readline:="
19 RDEPEND="${DEPEND}
20         gui? (
21                 ${PYTHON_DEPS}
22                 dev-python/pygobject:3
23                 sys-auth/polkit
24         )"
25
26 REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
27
28 pkg_setup() {
29         use gui && python-single-r1_pkg_setup
30 }
31
32 src_prepare() {
33         default
34
35         sed -i "/CFLAGS/d" Makefile.am || die
36
37         eautoreconf
38 }
39
40 src_configure() {
41         local myeconfargs=(
42                 --with-readline
43                 $(use_enable gui)
44         )
45         econf "${myeconfargs[@]}"
46 }
47
48 src_install() {
49         default
50
51         if use gui ; then
52                 docinto gui
53                 dodoc gui/{README,TODO}
54                 python_fix_shebang "${D}"
55         fi
56 }