dev-python/requests-toolbelt: keyworded 0.9.1 for ia64, bug #717946
[gentoo.git] / dev-util / rocminfo / rocminfo-2.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64"
14         S="${WORKDIR}/rocminfo-roc-${PV}"
15 fi
16
17 DESCRIPTION="ROCm Application for Reporting System Info"
18 HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
19 LICENSE="MIT"
20 SLOT="0/$(ver_cut 1-2)"
21
22 RDEPEND="dev-libs/rocr-runtime"
23 DEPEND="${RDEPEND}"
24
25 src_configure() {
26         local mycmakeargs=(
27                 -DROCM_DIR="${ESYSROOT}/usr"
28                 -DROCR_INC_DIR="${ESYSROOT}/usr/include"
29                 -DROCR_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
30         )
31         cmake_src_configure
32 }