sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-util / rocm-cmake / rocm-cmake-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocm-cmake/"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/RadeonOpenCompute/rocm-cmake/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64"
14         S="${WORKDIR}/rocm-cmake-roc-${PV}"
15 fi
16
17 DESCRIPTION="Radeon Open Compute CMake Modules"
18 HOMEPAGE="https://github.com/RadeonOpenCompute/rocm-cmake"
19 LICENSE="MIT"
20 SLOT="0"
21 RESTRICT="test"
22
23 src_prepare() {
24         sed -e "s:set(ROCM_INSTALL_LIBDIR lib):set(ROCM_INSTALL_LIBDIR $(get_libdir)):" -i "${S}/share/rocm/cmake/ROCMInstallTargets.cmake" || die
25         cmake_src_prepare
26 }