sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-util / rocm-cmake / rocm-cmake-0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ ${PV} == *9999 ]] ; then
9         EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocm-cmake/"
10         inherit git-r3
11 else
12         SRC_URI="https://github.com/RadeonOpenCompute/rocm-cmake/archive/${PV}.tar.gz -> ${P}.tar.gz"
13         KEYWORDS="~amd64"
14 fi
15
16 DESCRIPTION="Radeon Open Compute CMake Modules"
17 HOMEPAGE="https://github.com/RadeonOpenCompute/rocm-cmake"
18 LICENSE="MIT"
19 SLOT="0"
20 RESTRICT="test"
21
22 src_prepare() {
23         sed -e "s:set(ROCM_INSTALL_LIBDIR lib):set(ROCM_INSTALL_LIBDIR $(get_libdir)):" -i "${S}/share/rocm/cmake/ROCMInstallTargets.cmake" || die
24         cmake_src_prepare
25 }