dev-util/ply: Fix SRC_URI
[gentoo.git] / dev-util / re2c / re2c-1.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="tool for generating C-based recognizers from regular expressions"
7 HOMEPAGE="http://re2c.org/"
8 SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
9
10 LICENSE="public-domain"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
13 IUSE="debug"
14
15 PATCHES=("${FILESDIR}"/${P}-lexer-overflow.patch)
16
17 src_configure() {
18         econf \
19                 ac_cv_path_BISON="no" \
20                 $(use_enable debug)
21 }
22
23 src_install() {
24         default
25
26         docompress -x /usr/share/doc/${PF}/examples
27         dodoc -r README.md CHANGELOG examples
28 }